Resurrection

resurrection.jpg
I have been pretty sick since last night, which is probably why I have the time to post here today 🙂 I seem to have some kind of stomach bug right now which is keeping me in close proximity to my bathroom. But, inbetween bathroom breaks, I have been able to check my email at least, which is what started this whole ordeal.

While I was reading emails today I received one from my buddy Joel, who reminded me that I *still* have not gotten my stuff off my old servers. You see, when I moved here, I moved a month before my wife and daughter so that she could finish her school year. As such, I made a whole new computer infrastructure here and left all the old stuff running for my wife and daughter until the time of their move. At that time I just shut the old servers off there and shoved them into the car believing that I would get the stuff off of them sometime later on and add it to my new servers. Well, like I told Joel, I have succeeded in procrastinating for the last 8 months and that has never happened. Until today that is…

In a fit of boredom, I decided to grab those two servers out from underneath my endtable and finally pull all my important files off of them. I should probably preface this with the fact that I had *thought* I had all those files backed up somewhere, in fact, I thought they were backed up on an external usb drive *and* on cd/dvd. Guess what? Nope. Couldn’t find any of that anywhere, and that’s when scared the hell outa me when I finally plugged the servers in. You see, the first server is an old *old* NetBSD box (1.6.1) which I had used as an NFS server. The problem is that it had sat around for so lng that the hard drive was suffering from stiction. I booted the machine up 3 or 4 times trying to get it to start and then it hit me that I couldn’t find those backups. I started to get real worried. But, after a minute or three I resorted to the old rule “if it’s broke, kick it and try again”. So I dropped the thing on the table a couple times and magically the had drive decided to finally spin up so I could get my data off. The other server behaved much better, however, I had forgotten I had moved ssh to a nonstandard port, which took me a minute to correct.

At this point, I actually have all my old data in my laptop, and I can start to get things moved around to where they should go. Now I can finally do something with the old hardware hanging around in my livingroom too! I bet my wife will be ecstatic about that, until she realizes that she’s probably going to have to be the one to take that stuff to the storage facility 🙂

Anyhow, the moral of the story is twofold: #1 – Do your backups, and #2 – If it doesn’t work, kick it and then check again 😉

Be Sociable, Share!

Leave a Reply

You must be logged in to post a comment.